home *** CD-ROM | disk | FTP | other *** search
/ Chip 2007 January, February, March & April / Chip-Cover-CD-2007-02.iso / Pakiet bezpieczenstwa / mini Pentoo LiveCD 2006.1 / mpentoo-2006.1.iso / livecd.squashfs / var / db / pkg / sys-fs / reiserfsprogs-3.6.19 / reiserfsprogs-3.6.19.ebuild < prev    next >
Text File  |  2005-10-13  |  835b  |  32 lines

  1. # Copyright 1999-2005 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Header: /var/cvsroot/gentoo-x86/sys-fs/reiserfsprogs/reiserfsprogs-3.6.19.ebuild,v 1.8 2005/04/09 13:18:30 corsair Exp $
  4.  
  5. inherit flag-o-matic eutils gnuconfig
  6.  
  7. DESCRIPTION="Reiserfs Utilities"
  8. HOMEPAGE="http://www.namesys.com/"
  9. SRC_URI="http://www.namesys.com/pub/reiserfsprogs/${P}.tar.gz"
  10.  
  11. LICENSE="GPL-2"
  12. SLOT="0"
  13. KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 sparc x86"
  14. IUSE=""
  15.  
  16. src_unpack() {
  17.     unpack ${A}
  18.     gnuconfig_update ${S}
  19. }
  20.  
  21. src_compile() {
  22.     econf --prefix=/ || die "Failed to configure"
  23.     emake || die "Failed to compile"
  24. }
  25.  
  26. src_install() {
  27.     make DESTDIR="${D}" install || die "Failed to install"
  28.     dosym reiserfsck /sbin/fsck.reiserfs
  29.     dosym mkreiserfs /sbin/mkfs.reiserfs
  30.     dodoc ChangeLog INSTALL README
  31. }
  32.